Apa itu Native VLAN dan Bagaimana Cara Konfigurasi Native VLAN di Cisco


Apa itu Native VLAN?
Native VLAN adalah suatu aturan data frame yang memungkinkan switch yang tidak mendukung 802.1Q tag header agar bisa melintaskan traffic VLAN ke switch atau perangkat lain.

Apa ada switch yang tidak mendukung 802.1Q?
Jawabanya adalah ada. Yaitu switch cisco yang lama, yang mana sebenarnya cisco punya enkapsulasi VLAN sendiri yang yaitu ISL. ISL adalah cisco proprietary protocol atau protokol yang hanya didukung pada perangkat cisco dan tidak ada di perangkat vendor lain.

Apa perbedaan Native VLAN dengan Default VLAN?
Native VLAN adalah sebuah aturan yang memungkin switch cisco berinteraksi dengan perangkat lain untuk melintaskan paket VLAN.
Sedangkan Default VLAN adalah VLAN ID default saat suatu paket tidak ditandai sebagai paket VLAN. Maksudnya saat paket tersebut tidak ditandai sebagai VLAN 2-4096, maka paket tersebut otomatis dianggap VLAN 1 dan VLAN 1 itu "bebas komunikasi ke mana saja" tanpa perlu trunking.

Cara Kerja Native VLAN
Kita anggap topologi di atas pada trunking portnya sudah dikonfigurasi native VLAN-nya menjadi VLAN 100. Saat PC-1 mengirim data ke PC-3, Switch-1 akan menandai paket tersebut sebagai native VLAN agar bisa diteruskan ke Switch-2. Kemudian di Switch-2 paket tersebut ditandai kembali sebagai paket VLAN 100 dan diteruskan ke mac address tujuan.

Oke, sekarang kita mulai saja cara mengkonfigurasi native VLAN. Native VLAN perlu dikonfigurasi pada masing-masing port switch yang menghubungkan kedua switch tersebut. Dan perlu diketahui value default Native VLAN adalah VLAN 1, kita bisa cek Native VLAN pada suatu port dengan command: show interface nama_interface switchport

Kita konfigurasi seperti biasa (sudah di bahas di materi-materi sebelumnya):
- buat VLAN 100 pada kedua switch - atur juga access port dan trunking portnya

SWITCH1(config)#vlan 100
SWITCH1(config-vlan)#interface f0/2
SWITCH1(config-if)#switchport mode access
SWITCH1(config-if)#switchport access vlan 100
SWITCH1(config-if)#interface f0/1
SWITCH1(config-if)#switchport mode trunk

SWITCH2(config)#vlan 100
SWITCH2(config-vlan)#interface f0/11
SWITCH2(config-if)#switchport mode access
SWITCH2(config-if)#switchport access vlan 100
SWITCH2(config-if)#interface f0/24
SWITCH2(config-if)#switchport mode trunk

Untuk konfigurasi native VLAN kita masuk interface configurtion mode. Kemudian commandnya:
switchport trunk native vlan vlan_id

Kita konfigurasi native VLAN pada interface f0/1 di SWITCH1 dan f0/24 di SWITCH2.

SWITCH1(config)#interface f0/1
SWITCH1(config-if)#switchport trunk native vlan 100

SWITCH2(config)#interface f0/24
SWITCH2(config-if)#switchport trunk native vlan 100

Kemudian kita cek native vlan pada port tersebut:

SWITCH1(config-if)# show interface f0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 100 (VLAN0100)

SWITCH2(config-if)# show interface f0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 100 (VLAN0100)

Jika kedua port tersebut salah konfigurasi (berbeda native VLAN) maka akan muncul error seperti ini:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/24 (1), with SWITCH1 FastEthernet0/1 (100).

Untuk menghapus atau mengembalikan ke default, bisa menggunakan negate command (menambahkan command no pada command yang akan dihapus).

SWITCH1(config-if)#no switchport trunk native vlan 100

Atau dengan mengubahnya ke VLAN 1.
SWITCH1(config-if)#switchport trunk native vlan 1

Demikian materi tentang Allowed VLAN, sampai jumpa di materi berikutnya.

Disqus Comments