Konfigurasi Trunking Port pada Switch Cisco


Artikel ini adalah lanjutan dari materi Konfigurasi VLAN di Switch Cisco (Access Port). Di artikel tersebut kita sudah belajar cara membuat VLAN di Switch Cisco dan cara mengkonfigurasi access port pada Switch Cisco. Nah sekarang, kita akan belajar mengenai Trunking Port. Saya rekomendasikan untuk mempelajari materi sebelumnya jika teman-teman masih baru mengenal VLAN. Karena tidak semua materi yang sudah saya jelaskan akan dijelaskan lagi.

Kita refresh dulu ingatan kita tentang perbedaan access port dan trunking port pada VLAN yang sudah kita bahas di materi pertama Mengenal VLAN: Pengertian, Fungsi, dan Cara Kerjanya. Jadi perbedaannya access port itu hanya akan melintaskan satu VLAN ID saja, sedangkan trunking port digunakan untuk melintaskan lebih dari satu VLAN ID.

Kapan kita menggunakan access port dan kapan kita harus menggunakan trunking port?
Sesuai dengan perbedaanya, access port digunakan saat hanya ada satu VLAN yang melintasi satu media transmisi (kabel), jadi kita konfigurasi port di switchnya menjadi mode access vlan. Sebaliknya, jika ada lebih dari satu VLAN maka kita harus mengkonfigurasi port interface switch menjadi trunking port. Dalam praktiknya nanti kita akan sering melihat konfigurasi access port digunakan untuk menghubungkan Switch ke PC atau Switch ke Router yang bukan inter-vlan. Sedangkan trunking port digunakan untuk menghubungkan Switch ke Switch atau Switch ke Router yang digunakan untuk inter-vlan.

Gambar 1 - Topologi VLAN 2 Switch

Oke kita mulai penerapan trunking portnya pada topologi di atas. Ceritanya ada satu jaringan dengan Network ID 192.168.10.0/24 tapi terpisah di dua lantai. Komputer harus bisa saling terhubung dengan sesama bidang pekerjaanya tapi tidak boleh terhubung dengan bidang pekerjaan yang berbeda. Karena ini sebenarnya lanjutan dari topologi sebelumnya, hanya saja disini saya tambahkan satu switch lagi. Jadi, saya anggap teman-teman sudah mengkonfigurasi IP Address di setiap komputer sesuai aturan di materi sebelumnya: Konfigurasi VLAN Cisco (Access Port).

Pastikan semua komputer dapat saling terhubung :

Gambar 2 - Uji Coba VLAN 2.1

Jika sudah konfigurasi IP pada setiap komputer, kita mulai konfigurasi VLAN dari SWITCH-1 dulu.

SWITCH-1(config)#vlan 10
    SWITCH-1(config-vlan)#name DIREKTUR
    SWITCH-1(config-vlan)#vlan 20
    SWITCH-1(config-vlan)#name MANAGER
    SWITCH-1(config-vlan)#vlan 30
    SWITCH-1(config-vlan)#name CUSTOMER_SERVICE

Kemudian kita validasi atau cek database VLAN apakah vlan sudah sesuai dengan yang kita buat.
SWITCH-1(config-vlan)#do show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                    Gig0/1, Gig0/2
    10   DIREKTUR                         active    
    20   MANAGER                          active    
    30   CUSTOMER_SERVICE                 active    
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    

Kita konfigurasi access vlan pada interface yang terhubung ke PC. Kita tidak akan mengelompokan interface seperti materi sebelumnya, di materi ini kita hanya akan mengkonfigurasi port yang terhubung ke PC saja.

SWITCH-1(config)#interface f0/1
    SWITCH-1(config-if)#switchport mode access
    SWITCH-1(config-if)#switchport access vlan 10
    SWITCH-1(config-if)#interface f0/5
    SWITCH-1(config-if)#switchport mode access
    SWITCH-1(config-if)#switchport access vlan 20
    SWITCH-1(config-if)#interface f0/11
    SWITCH-1(config-if)#switchport mode access
    SWITCH-1(config-if)#switchport access vlan 30

Cek database VLAN apakah sudah benar sesuai dengan yang kita inginkan.
SWITCH-1(config)#do sh vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/6
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                    Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                    Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                    Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                    Fa0/24, Gig0/1, Gig0/2
    10   DIREKTUR                         active    Fa0/1
    20   MANAGER                          active    Fa0/5
    30   CUSTOMER_SERVICE                 active    Fa0/11
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    

Selanjutnya kita beralih ke SWITCH-2, pertama kita buat database VLAN-nya terlebih dahulu seperti di SWITCH-1.

SWITCH-2(config)#vlan 10
    SWITCH-2(config-vlan)#name DIREKTUR
    SWITCH-2(config-vlan)#vlan 20
    SWITCH-2(config-vlan)#name MANAGER
    SWITCH-2(config-vlan)#vlan 30
    SWITCH-2(config-vlan)#name CUSTOMER_SERVICE
Teman-teman bisa mengecek VLAN yang sudah dibuat terlebih dahulu, atau kalau sudah yakin bisa lanjut. Hehe.

Jika sudah, kita konfigurasi access vlan di setiap port yang terhubung ke PC.

SWITCH-2(config)#interface f0/4
    SWITCH-2(config-if)#switchport mode access
    SWITCH-2(config-if)#switchport access vlan 10
    SWITCH-2(config-if)#interface f0/10
    SWITCH-2(config-if)#switchport mode access
    SWITCH-2(config-if)#switchport access vlan 20
    SWITCH-2(config-if)#interface f0/20
    SWITCH-2(config-if)#switchport mode access
    SWITCH-2(config-if)#switchport access vlan 30

Kita cek apakah konfigurasi VLAN-nya sudah sesuai.
SWITCH-2(config-if)#do show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/5
                                                    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                    Fa0/19, Fa0/21, Fa0/22, Fa0/23
                                                    Fa0/24, Gig0/1, Gig0/2
    10   DIREKTUR                         active    Fa0/4
    20   MANAGER                          active    Fa0/10
    30   CUSTOMER_SERVICE                 active    Fa0/20
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active  

Sampai sini, saat kita cek, komputer dalam VLAN yang sama tapi beda switch belum bisa saling terhubung. Hal ini disebabkan karena paket VLAN belum bisa melintas dari SWITCH-1 ke SWITCH-2 dan sebaliknya.

Gambar 3 - Uji Coba VLAN 2.2

Di sinilah kita memerlukan trunking port untuk melintaskan paket VLAN. Kita perlu mengkonfigurasi interface yang menghubungkan SWITCH-1 dengan SWITCH-2 menjadi trunking port. Yaitu interface GigabitEthernet0/1 pada SWITCH-1 dan GigabitEthernet0/1 pada SWITCH-2.

SWITCH-1(config)#interface g0/1
    SWITCH-1(config-if)#switchport mode trunk

Kemudian untuk validasi atau pengecekan interface trunk atau trunking port menggunakan command show interfaces trunk jika melalui privilege mode atau jika melalui configuration mode tambahkan "do" di depannya.
SWITCH-1(config-if)#do sh interfaces trunk 
    Port        Mode         Encapsulation  Status        Native vlan
    Gig0/1      on           802.1q         trunking      1
    
    Port        Vlans allowed on trunk
    Gig0/1      1-1005
    
    Port        Vlans allowed and active in management domain
    Gig0/1      1,10,20,30
    
    Port        Vlans in spanning tree forwarding state and not pruned
    Gig0/1      1,10,20,30

Lakukan konfigurasi juga pada interface GigabitEthernet0/1 pada SWITCH-2.

SWITCH-2(config)#interface g0/1
    SWITCH-2(config-if)#switchport mode trunk
Kemudian untuk pengecekan jika command terlalu panjang bisa disingkat do sh int tr, seperti ini:
SWITCH-2(config)#do sh int tr
    Port        Mode         Encapsulation  Status        Native vlan
    Gig0/1      on           802.1q         trunking      1
    
    Port        Vlans allowed on trunk
    Gig0/1      1-1005
    
    Port        Vlans allowed and active in management domain
    Gig0/1      1,10,20,30
    
    Port        Vlans in spanning tree forwarding state and not pruned
    Gig0/1      1,10,20,30

Sekarang, kita coba cek apakah komputer dengan VLAN yang sama sudah terhubung. Cek juga koneksi komputer yang berbeda VLAN.

Gambar 4 - Uji Coba VLAN 2.3

Jika seperti Gambar 4 atau sudah sesuai tujuan kita yaitu komputer dengan VLAN yang sama terhubung dan yang berbeda VLAN tidak terhubung, berarti konfigurasi kita sudah berhasil. Jika belum sesuai silakan cek lagi konfigurasinya apakah sudah benar dengan command show running-config jika dari privilege mode atau do show running-config jika dari configuration mode.

Cara Kerja Trunking Port

Kita akan mencoba mengirimkan paket dari CUST-1 ke CUST-2, dana kita amati menggunakan simulation mode.

Gambar 5 - Event List 2

Kemudian kita amati Ethernet Frame saat paket akan keluar pada SWITCH-1 di interface Gig0/1. Jika teman-teman mengirim paketnya dari CUST-1 ke CUST-2, bagian yang saya maksud ada pada event list nomor 2 at device SWITCH-1, klik itu. Kemudian pindah tab ke Outbound PDU Details.

Gambar 6 - 802.1Q Tag Header di Switch-1

Pada ethernet frame di situ akan ada tambahan tag header 802.1Q. Tag header tersebut yang membuat traffic VLAN bisa melintas atau keluar ke switch lain.

Oke, demikan pembahasan mengenai trunking port. Berikutnya, kita akan membahas tentang Allowed VLAN: Membatasi VLAN pada Trunking Port.

Disqus Comments