Pembahasan Soal Networking Competition Techcomfest 2019 (Troubleshooting)


Techcomfest (Technology Computer Festival) merupakan kegiatan perlombaan bidang IT yang diselenggarakan oleh Unit Kegiatan Mahasiswa Polythecnic Computer Club (UKM PCC) Politeknik Negeri Semarang. Kegiatan ini dilaksanakan setiap tahun. Pada tahun ini, Final Techcomfest diselenggarakan pada 23 Februari 2019 lalu di Politeknik Negeri Semarang dengan 3 cabang lomba, yaitu Design Competition, Network Competition, dan Software Development Competition. Pesertanya adalah pelajar SMA/SMK sederajat tingkat Jateng dan DIY serta Mahasiswa Umum tingkat nasional.

Pada kesempatan kali ini, kami akan berbagi sedikit pengalaman dalam mengerjakan Soal Troubleshooting Network Competition Techomfest 2019. Jika teman-teman belum mempunyai soalnya, silakan mendownload telebih dahulu di link berikut:
Download Soal Networking Techcomfest 2019

TOPOLOGI :



INSTRUKSI :

  • Pastikan Anda menggunakan Cisco Packet Tracer versi 7.1.1 atau di atasnya.
  • Waktu pengerjaan 1 jam.
  • Save konfigurasi secara berkala.
  • Terdapat 10 Tickets yang harus di cari dan kerjakan.
  • Pastikan Router di VLAN 10, 200, 3000 bisa ping ke google.com.
  • Catat ticket yang sudah solve, ke dalam word dan kumpulkan bersama dengan soal.


PEMBAHASAN :
Dalam menegerjakan soal troubleshooting, Kami biasa memulai dari layer yang paling bawah (access layer) sampai layer tetinggi (core layer). Tujuannya supaya lebih terstruktur pengerjaannya.

1. Mulailah dari layer paling bawah, yaitu VLAN 10, 200, dan 3000. Lakukan pengujian dari R-SRV ke (Client-DHCP1, Client-DHCP2, Client-DHCP3). Kamu akan mendapati keempat device tersebut belum terkoneksi kan.



2. Coba masuk ke SW-ACC1, Kamu akan menemukan error seperti ini.


Artinya konfigurasi VTP tidak tepat, lakukan konfigurasi ini pada SW-ACC1:
SW-ACC1(config)#vtp mode client
SW-ACC1(config)#vtp domain T3ch0mf35t!-d0m41N
SW-ACC1(config)#vtp password M!5s10N


3. Pada SW-ACC2 coba ubah VTP-nya menjadi transparent.
SW-ACC2(config)#vtp mode transparent
Kemudian cek semua konfigurasi dengan perintah do show run. Fokus ke bagian VTP.
Nah, disitu terlihat jelas vtp password M!s51oN, seharusnya M!5s10N. Maka ubahlah password VTP-nya dan set lagi ke mode client.
SW-ACC2(config)#vtp mode client
SW-ACC2(config)#vtp domain T3ch0mf35t!-d0m41N
SW-ACC2(config)#vtp password M!5s10N


4. Selanjutnya cek konfigurasi di R-SRV (show run). Fokus ke interface e0/0/0.

Karena interface tersebut langsung mengarah ke Server DHCP maka tidak diperlukan DHCP Relay, maka hapus konfiguurasi dhcp relaynya :
R-SRV(config)#int e0/0/0
R-SRV(config-if)#no ip helper-address 10.10.10.2


5. Masih di R-SRV, cek lagi konfigurasinya (show run) dan fokus ke interface e0/1/0. Karena interface tersebut mengarah ke VLAN 3000, maka kita harus menghapus konfigurasi yang tidak diperlukan pada interface e0/1/0 dan melakukan konfigurasi interface virtual untuk VLAN 3000.
R-SRV(config)#int e0/1/0
R-SRV(config-if)#no ip address
R-SRV(config-if)#no ip helper-address 10.10.10.2
R-SRV(config-if)#int e0/1/0.3000
R-SRV(config-subif)#encapsulation dot1Q 3000
R-SRV(config-subif)#ip address 10.0.30.1 255.255.255.0
R-SRV(config-subif)#ip helper-address 10.10.10.2


6. Cek kembali konfigurasi R-SRV (show run), sekarang fokus ke interface yang mengarah ke vlan 10 dan 200 (f0/1.10 dan f0/1.200. Interfcace tersebut belum dikonfigurasi DHCP Relay, maka kita perlu mengkonfigurasinya agar Router di VLAN bsia mendapatkan ip dinamis dari DHCP Server (10.10.10.2).
R-SRV(config-if)#int f0/1.10
R-SRV(config-subif)#ip helper-address 10.10.10.2
R-SRV(config-subif)#int f0/1.200
R-SRV(config-subif)#ip helper-address 10.10.10.2


7. Sekarang kita beralih ke SW-ACC3, cek konfigurasinya (show run) dan fokus ke konfigurasi switching vlan pada setiap interfacenya. Di situ terlihat kesalahan konfigurasi. Interface yang mengarah ke R-SRV (f0/1) seharusnya dijadikan trunk dan interface yang mengarah ke Client3-DHCP (f0/2) seharusnya access ke vlan 3000.
Kita konfigurasi trunking dulu di interface interface f0/1.
SW-ACC3(config)#int f0/1
SW-ACC3(config-if)#no switchport access vlan 30
SW-ACC3(config-if)#switchport mode trunk


Sebelum konfigurasi access vlan di interface f0/2, kita buat vlannya terlebih dahulu.
SW-ACC3(config)#vlan 3000
Pasti akan muncul error berikut.

Jadi, sebelum membuat vlan kita perlu mengubah dulu VTP-nya menjadi mode transparent. Kemudian konfigurasi acces vlan di interface f0/2.
SW-ACC3(config)#vtp mode transparent
SW-ACC3(config)#vlan 3000
SW-ACC3(config-vlan)#name SYSADMIN
SW-ACC3(config-vlan)#int f0/2
SW-ACC3(config-if)#switchport access vlan 3000


8. Konfigurasi access layer cukup itu dulu, lakukan pengecekan antar host. Pastikan Router di dalam VLAN mendapatkan ip dhcp dan bisa terhubung ke R-SRV dan Server DHCP. Lanjut ke distribution layer.


Pertama kita perlu mengecek koneksi direct antar router di distribution layer (belum melewati routing). Yaitu R-SRV ke R-DIST1, R-DIST1 ke R-CORE3, R-CORE3 ke R-CORE2, R-CORE2 ke R-CORE1, R-CORE3 ke R-CORE1. Jika semuanya terhubung, artinya konfigurasi ip address sudah benar dan 99,9% aman. Lanjut ke tahap berikutnya.


9. Tahap berikutnya, mulailah melakukan pengecekan koneksi non-direct atau koneksi yang sudah melawati router lain (memerlukan proses routing). Mulailah dari yang terdekat dengan acces layer sampai yang terdekat dengan core layer.
Kita akan menemukan masalah saat mengecek koneksi dari Router Client ke R-DIST1.


Untuk mencari penyebabnya, gunakan mode simulation (tekan Shift + S). Play, kemudian amati kemana rute paket dikirimkan, dan berhentilah (stop) saat terlihat kejanggalan. Lihat detail masalahnya.
Di situ ada keterangan "The routing table does not have a route to the destination IP address.". Yang intinya tidak ditemukannya table routing yang cocok dengan koneksi tersebut. Langkah awal kita cek dulu konfigurasi routing di R-SRV (show run) :


Di situ terlihat bahwa terdapat konfigurasi passive interface untuk f0/0, padahal interface tersebut mengarah ke distribution layer. Jadi kita perlu menghapusnya.
R-SRV(config)#router ospf 17111
R-SRV(config-router)#no passive-interface f0/0

Tunggu sampai ada update route ospf seperti ini :
Kemudian lakukan pengecekan dari Router Client ke R-DIST1. Pasti masih tetap failed.

10. Seperti tadi, gunakanlah Simulation Mode untuk mencari tau penyebabnya. Penyebabnya pasti paket bermasalah saat sampai di R-DIST1 dengan keterangan yang sama "The routing table does not have a route to the destination IP address.". Maka sekarang kita cek konfigurasi routing di R-DIST1.

Di situ, terdapat konfigurasi hello-interval 100 di interface yang mengarah ke R-SRV. Padahal di R-SRV konfigurasi dead-interval masih default (40). Hello interval 100 artinya R-DIST1 baru akan mengirim hello packet setelah 100 detik. Sementara R-SRV telah menganggap R-DIST1 mati (tidak mengirim hello packet) setelah 40 detik (sebelum R-DIST1 mengirimkan hello packet).

Hello interval : mendefinisikan seberapa sering router mengirimkan hello packet pada interface tersebut (default 10 detik).
Dead interval : mendefinisikan batas waktu tunggu router dalam menerima hello packet sebelum menganggap interface tersebut mati atau tidak ada hello packet (default 40 detik).


Maka kita perlu menghapus konfigurasi hello-interval tersebut :
R-DIST1(config)#interface f0/1
R-DIST1(config-if)#no ip ospf hello-interval 100

Sekarang, coba cek koneksi dari Router Client ke R-DIST1, harusnya connected (succesfull).

11. Kemudian kita cek koneksi Router Client ke R-CORE3, pasti failed. Seperti biasa gunakanlah Simulation Mode untuk mencari penyebabnya.

Lagi-lagi masalah routing table, kita cek konfigurasi di R-CORE1 dan R-CORE3. Maka akan ditemukan konfigurasi HSRP, jadi kita harus membuat default route di R-DIST1.

R-DIS1(config-if)#ip route 0.0.0.0 0.0.0.0 10.30.0.4

Sekarang lakukan uji koneksi dari Router Client ke Router Core, harusnya connected semua :


12. Sekarang, kita mulai masuk ke core layer. Kita cek koneksi direct antara R-CORE1 dan ISP, pasti failed. Berarti masalahnya ada pada ip address di interface terkait.


Di situ terdapat keterangan ip address ISP 23.2.17.0/22, namun saat dicek di R-CORE1 ip addressnya 23.2.20.255 dan pada Router ISP ip addressnya 23.2.17.0/20, Jadi, kita perlu menyamakan network id keduanya.

Kita konfigurasi ip interface g0/0/0 R-CORE1 :
R-CORE1(config)#int g0/0/0
R-CORE1(config-if)#ip address 23.2.19.254 255.255.252.0

dan pada interface g0/2/0 Router ISP :
ISP(config)#int g0/2/0
ISP(config-if)#ip address 23.2.17.1 255.255.252.0

Sekarang coba ujicoba lagi dari R-CORE1 ke ISP. Lanjut R-CORE1 ke google.com.

13. Langkah berikutnya yaitu cek koneksi R-CORE3/R-CORE2 ke ISP, pasti masih failed. Coba cek konfigurasi pada R-CORE1 bagian NAT.

Di interface g0/0/0 seharusnya sebagai output interface, bukan input interface.
R-CORE1(config)#int g0/0/0
R-CORE1(config-if)#ip nat outside


Selain itu belum ada routing yang mengarah ke core layer baik di R-CORE2 mapun R-CORE3, maka kita perlu melakukan konfigurasi default routing di kedua router tersebut.
R-CORE2(config)#ip route 0.0.0.0 0.0.0.0 10.10.0.1
R-CORE3(config)#ip route 0.0.0.0 0.0.0.0 10.20.0.1

Sebenarnya sampai sini saja task agar Router Client bisa ping ke google.com sudah terselesaikan.


Namun jika melihat presentasi nilai masih 88%, konfigurasi dead interval pada R-CORE3 harus dihapus agar menjadi 100%.
R-CORE3(config)#interface f0/0
R-CORE3(config-if)#no ip ospf dead-interval 1000


Untuk Client-DHCP3 belum bisa mendapatkan IP DHCP, sampai saat ini belum Kami temukan solusinya. Mungkin teman-teman yang tahu bisa share di kolom komenter. Hihi.
Sekian. Mohon dikoreksi jika ada yang salah.
Disqus Comments